3 like 0 dislike
1.5k views

Write a program that asks the user to type an integer N and find out all the factors of N and display it on screen.

寫一個程式 輸入一個整數N,找出N的所有因數

Example input 1

10

Example output 1

1 2 5 10

Example input 2

24

Example output 2

1 2 3 4 6 8 12 24

 

[Exam] asked in Midterm by (12.1k points)
ID: 32709 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 1.5k views

47 Answers

0 like 0 dislike
Hidden content!
*** *** * *
int a,i;

int main()
{
* ** *** ***** *

**** *** ****

  {
* *** *** * * * **** ** * **
* *** * *** *** * ** ** * * ** ** **
** *** * ** * * ** *** * * * **** ** * ** ** ",i);
** ** ** ** * ***** ********* * ** *** *
  }
}
answered by (-336 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main()
{
***** * **** ** * ** * a,b,c;
** ***** ** * ** * * * ** * * * ** *** ****
* * * ***** ******** * * (b=1;b<=a;b++)
* ** * * * ** * * * ***
* * * * * * ** * * * ** * * **
* * ***** * ** * * ** ** **** *
** **** ** * ** ** * * ** ** ** * * *
* *** ** *** * * * * * * ** * * ** ** * * * ** * ** ** %d",b);
* ** *** * * * * * ** * ** ** * **
    }
}
90/100 answered by (-255 points)
edited by
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
    int a,b,c=0;
*** ***** ** * *** * **** **** ** *** *** *
    for (b=1;b<=a;b++)
    {
* * * ************* * * * ** * * * * * * * (a%b==0)
** *** * **** ** ** * *** *** * ** **
* * ** * ******* *** ***** ** **** ** * *** * * * ** * * ** **
* ***** ** ** * * ***** *** *** * ** ** * ** ** **** *** * *** * ***
** ** ***** * ** * * * ** **** *** * ** * * ***** ***** * *** ** * ** * * *
** ** * * * * ******* ** * * ** * *** ** ******* * * * ** * * * *
** *** * ** * * * * * * * ** * * * * ** * ** ** ** * ***** * **
** * *** * * * *** ** ***** ** ** ** *** ******* * * * * * ** *** *** *
** *** **** ** * * ** * ** * ** * * ** * *** *** *** ** ** * * * ** ** ** ** %d",b);
*** * * * * * * ** ** ** * ** * * * ** ** * *


    }
return 0;
}
answered by (-229 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>

int main() {
* * * * * ** ** * *** a,i=1;
*** ** * ** ** ** ** * * * **** *** * &a);
*** **** * * ** ** * * * ***** {
**** ** *** * * *** * * * **** * * ** ** {
** *** * * *** ** *** *** ** * * * * * * * * * * * * * **** *** ", i);
* ** *** * * **** * * ** * * * * *** * **
*** ** ********* *** ** ***** **** * * * *
    }
** * * * * ** * * * ** ***** a);
}
answered by (-120 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main (void)
{
** * ***** *** *** * ** a,b,c;
** *** ***** ****** ** * ***** **** * * *
* ******** * * * *
* ** * ** * *** ** ** **** (b=a;b>0;b--){
* * **** * * * ** *** * ** ** ** * * * *** * * * (a%b==0){
*** ** * *** * ** * * * * * * * ** *** *** *** ** ** * * (c!=1){
* * *** * ** *********** ****** * * * ** * * * ** ** ** * ***** * ** * ** * * * (" ");
* *** *** * ** ** *** **** * *** *** ** ** ** *** * *****
* * ** * ** * * ** * * * **** * * * * ** **** * ***** * *
* **** *** ** ** **** * * *** * * * * * * * *** * ** * * * ("%d",a/b);
* ** * * * ** * * ** * ** ** * * ****
    }
}
answered by (-204 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main(void)
{
***** * *** **** * * ** ** n,i,f;
** ** * ** * *** * * * * * *** * * *****

*** * ** ** * ** ** * ****
    {
*** * *** ** * * * * ** * *** * *
* * ***** * ** * **** * ** *** * * * *** ** *** ***** ** **
* * ** * * ** * ** ** ** * *** **** *
* * * *** * * * ** **** * ** * * *** * *** *** *** ** ******** ** ** * ");

** ****** *** * *

* ** * ** ** * ** * * **** * 0;
}
answered by (-249 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a,b,c=0;
* * *** ****** ** ** * ** ***** **** ** * * ***
* * * * **** * ** * *** ** *** ** *
    {
* * * ***** * ** * * * * * * * ** * * ** ** *
* * ** ** **** ** ***** * **** **
* * * * * * * * * * * ** * * * * ** * **** ***** **** ** **** *
* *** **** ** ** * * * ** * *** ** **** *** *** * **** * * * * * *** *** *
** **** * * ****** *** **** * * * * * * * ***** ** ****** * * * * ******** * * * * * * ** * *
* **** * * *** *** * * **** ** * * * ** ** * ** * * * **** * ****** *** ***** * *
*** ** *** * * *** * * ****** *** *** * *** * * ** *** *
* * **** **** * **** ** ** * *** * **** * ** * * *** *
*** ** * * **** *** *** ** * * * ** ** * * * * * * ** * * *** * * ***** * ** *** ** ** ** * * %d",b);
*** * ** * * * ** * * * ** * **** **** ***
    }
    return 0;
}
answered by (-498 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
* ** * ** * **
int main (void)
{
*** ***** * *** **** ** a,b,c;
* *** *** **** ******* *** ****** *** ** ** *
***** ***** * * ** ** * * (b=a;b>0;b--){
* * ** * * * *** ******* * * * * * * (a%b==0){
*** ** ** ***** *** * ** ** **** *** ** **** *** * ** * * ("%d ",a/b);
* * * *** * * * ******* * *
** * ** * ** ** *
}
answered by (-204 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include * **
int main()
{
* * * * * ** ****** a,b;
* * * ** ******** ** * * * * ** ** * *
** ** ** * * ***** ** * ** * 2 5 * ** *
* * * * **** * ** ***** * *** *
* * * **** **** * 2 3 4 6 8 12 24",b);
*** ** * * * * * * * 0;



}
answered
0 0
prog.c: In function 'main':
prog.c:5:10: warning: too many arguments for format [-Wformat-extra-args]
    scanf("number",&a);
          ^~~~~~~~
prog.c:6:11: warning: too many arguments for format [-Wformat-extra-args]
    printf("1 2 5 10",a);
           ^~~~~~~~~~
prog.c:7:10: warning: too many arguments for format [-Wformat-extra-args]
    scanf("number",&b);
          ^~~~~~~~
prog.c:8:11: warning: too many arguments for format [-Wformat-extra-args]
    printf("1 2 3 4 6 8 12 24",b);
           ^~~~~~~~~~~~~~~~~~~
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
** ** ** ** ** * number, i;

* * *** ** *** *** ***** * ** * &number);

* * * ******* * **** * ** i <= number; ++i)
**** * **** * ** ****
**** * * **** **** **** * ** * ** * * * * * * * * == 0)
* * *** ****** * *** * * ** ** * *
** ** * ** * *** * * *** ** ** ** ** *** * * * **** * ****** ** * * ", i);
** *** * ********** * ** * * *** **** * *** **
* * * ** * **** * * ** * *
* * * * * * * *** ** ** * **** 0;
}
90/100 answered by (-233 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.69.58.53
©2016-2024

Related questions

0 like 0 dislike
21 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36754 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 961 views
0 like 0 dislike
72 answers
[Exercise] Coding (C) - asked Nov 2, 2017 in Chapter 6: Loops by semicolon (5.2k points)
ID: 29831 - Available when: 2017-11-02 18:00 - Due to: Unlimited
| 2k views
0 like 0 dislike
22 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36753 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 970 views
0 like 0 dislike
10 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36752 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 511 views
12,783 questions
183,443 answers
172,219 comments
4,824 users