3 like 0 dislike
3.9k views

Write a program that asks the user to type an integer N and find out all the factors of N and display it on screen.

寫一個程式 輸入一個整數N,找出N的所有因數

Example input 1

10

Example output 1

1 2 5 10

Example input 2

24

Example output 2

1 2 3 4 6 8 12 24

 

[Exam] asked in Midterm by (12.1k points)
ID: 32709 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 3.9k views

47 Answers

0 like 0 dislike
Hidden content!
#include * ******* * **
#include ** ** *******

int main()
{
***** *** * ** *** * a,i,c=0;
*** ** * * ** *** * * * * * * *
** * *** ** ***** *** **** * ****
*** ** * ***** ** **
**** *** *** **   if(a%i==0)
******* * * *   {
*** *   * * *** ** ** ** ** *
* * * ** * ** * * * ** * * *
****   * ** *** * ***** **   ** * ** * ** ** **
********   ******** ** * *   c++;
** *   * * ** **** ***
*** ******* * * * ** * * *
****   * ** * ** * * ** * * ***** ***
* * * ** }
** ** *** * * **
** ** * * * *
* **** * ** * 0;
}
answered by (-258 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
** * * * *** ** * * * ** b;
** * * ** *** *** * **** a;
* **** * ** ** ******* ** * ** * ** &a);
** * *** * * * (b=1; b<=a; b++)
******** * * * * *** ** ** * (a%b==0)
* * * *** * ** ** *
* ** * ** * *** * * ** ** *** * * ************* * ***** ***
**** * * *** * * *** ** * * * * ** *** (b!=a)
* **** ***** *** * ** * * ** ********* * ** ** * * *** *** * *** * ** ** * ");


** * ** ** *** ** *****
return 0;
}
answered by (-140 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
*** ** ** **** * **** ** n;
* ** *** * ** ** ** a;
* * **** **** ** ***** ****** ** * ** * &n);


* * ****** ** * * (a=1; n<=a; a++)



* * ** * * ** ** *** * ** ** ** **** (n%a==0)
** ******* ***** *
*** * * * * *** ** * * * * ******* **** ** * ** ** * **** * ** a);
* * ** ** ******* * ** *** * ** ** * * (a!=n)
* * * ** **** * ***** ** ** * * * * * ** * ** * ****** * ** ** * * ");


* *** * * *******
return 0;
}
answered by (-140 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include * * *** *
int main(){
* ** *** ***** ****** n,i;
* * * * * * *** ***** * *** ******** *
* * * * ** ****** * * ***** ******
** * * ** * *** *** * * ****** * * * * * (n%i==0) ** * * %d",i);}
return 0;

}
90/100 answered by (-32 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
** * * *


int ***
{
int * *
**** ** ** 1 * * * *****
* * **** *** ** ** *

**** * * * **
{
d=a%c
if (d=0)
******** *** * *** **** ** * * * * * *
}
* 0;
}
answered by (-32 points)
0 0
prog.c: In function 'main':
prog.c:13:1: error: expected ';' before 'if'
 if (d=0)
 ^~
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main(void){
    int n,i;
** * * * * *** ** * * ** * ** **
    for(i=1;i<=n;i++)
* **** * **** * ** * ** *** ** * * *** (n%i==0)
******* *** * * ** *** ** * *** ** *
** * *** * **** ** **** ****** * * * * ** ** * **** *** * * ** * * *
***** ** *** * * * ** ** ** * * * ***** * **** * *
* ****** * * * * ** ** *** ** * **** ***
** * ** * ** ** * * *** ******** ** *** **
****** * * * ***** ** *** * * * ** * ** *** * ******* ** * ***** * * * ");
* * *** **** *** *** * * *** ****** * * **
** * * ** * * ***** * * * ** * *** * * **


return 0;

}
answered by (-32 points)
0 0
prog.c: In function 'main':
prog.c:4:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'int' [-Wformat=]
     scanf("%d",n);
             ^
0 like 0 dislike
Hidden content!
* ** *** ** * ***
int main()
{
  int a, b, i;
  
* * ** **** ** * &a,&b);
  
  for(i=1; 1<b; i++);{
* ** ** * * * * * * * *
** *** ** **** * ** *
* * * * ** ** ****** ** * *
*** * * * * ****** *** * ***** * * ******
* * ** * * ** * * *** * * * * ** *** **
** * ** * ** ** ******* * * * ***
** ** ** * * * * * * *** ** * * ** ** *** *
* ********** ** * * * * ** *** ***
* ** ** *** * *** ******* *** * *** 0;
*** * *** ** * *
* ** * * **** * *** **
answered by (-167 points)
0 0
prog.c: In function 'main':
prog.c:10:13: error: lvalue required as left operand of assignment
     if(a%i+1=0){
             ^
prog.c:14:7: error: expected '}' before 'else'
       else{
       ^~~~
prog.c:18:5: error: expected declaration or statement at end of input
     }
     ^
0 like 0 dislike
Hidden content!
**** *** * *** **
int main()
{
** * * a, b, i;
* ** * ** ** *
* *** * ** * ****** * * * **** ** ***
** * *** *
**** * * ** 1<b; i++);{
** ** *** * * * ***
*** **** * ** ** ** * * **
*** *** * **** * * **
  
answered by (-167 points)
0 0
prog.c: In function 'main':
prog.c:10:5: error: expected expression at end of input
     if(
     ^~
prog.c:10:5: error: expected declaration or statement at end of input
prog.c:10:5: error: expected declaration or statement at end of input
0 like 0 dislike
Hidden content!
#include *** ** * *
int main()
{
* * ******* *** * * a,b;
* **** ** * * * * * ** ***** *** * * ***
*** *** * ** * ** * * 2 5 * ** ****** *
* * * * **** 0;



}
answered by (42 points)
0 0
prog.c: In function 'main':
prog.c:6:10: warning: too many arguments for format [-Wformat-extra-args]
    scanf("number",&a);
          ^~~~~~~~
prog.c:7:11: warning: too many arguments for format [-Wformat-extra-args]
    printf("1 2 5 10",a);
           ^~~~~~~~~~
0 like 0 dislike
Hidden content!
******** * * * *

*** *** * * main()
{
** * **** * ** **** *** a,b;
** * *
for (b=1; *** ** *
** ****** *** * * * * ** ** (a%b==0)
{
* * *** * ** * ****** * * ***** ** **


if (b!=a)
* *** *** ***** **** * **** ** *** *

}
return 0;
}
answered by (-254 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.130.42
©2016-2025

Related questions

0 like 0 dislike
21 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36754 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 2.4k views
0 like 0 dislike
72 answers
[Exercise] Coding (C) - asked Nov 2, 2017 in Chapter 6: Loops by semicolon (5.2k points)
ID: 29831 - Available when: 2017-11-02 18:00 - Due to: Unlimited
| 6.2k views
0 like 0 dislike
22 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36753 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 2.4k views
0 like 0 dislike
10 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36752 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 1.4k views
12,783 questions
183,443 answers
172,219 comments
4,824 users