1 like 1 dislike
2.7k views

Write a program that reads an integer (1-4 digits) and displays the number of its digits and their sum. For example, if the number is 1234, the program should display 4 and 10

寫一個輸入四位整數 輸出數字的位數和位數的總和。例如,數字是1234程式會輸出4和10。

More information about Loops here.

 

Example input:

1234

Example output:

4 10

 

Example input 2:

245

Example output:

3 11

 

[Exercise] Coding (C) - asked in Chapter 6: Loops by (5.2k points)
ID: 28914 - Available when: 2017-10-26 18:00 - Due to: Unlimited

edited by | 2.7k views

85 Answers

1 like 0 dislike
Hidden content!
#include<stdio.h>
int main(){
* * ** * **** * ** * i;
* * *** **** ** ** * sum=0,counter=0;
** *** ** * * ** ** **** ** *** ** * ** *
**** *** *** **** * * {
** * * *** * * * * * * ** * * ** ****** *
* * * ** * ** ** ** * * ** ** * ******* i%10;
**** ** ** ** * * ** **** ** * * * ***** **** * ***
** * * * * * * ***** *** *** * * **

** ******* * ** ***** ** * *** %d",counter,sum);
***** * *** ** *** * * * * 0;
}
answered by (-116 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include ** ********
int main (void)
{
** ** ** ** * ** ***** n, count, sum, t, remainder;
* * * * ** * ** *** * * * = 0;
** ** ***** * ** * = 0;
* * * * *** * * * * * **** * ** *** &n);
* ** ** * ** ** * ** = n;
** ***** **** ** *** ****** ** (n != 0)
* ***** * * * **** **

** * ** * **** ** ** ***** ****** * * * * * = n % 10;
* * *** ** * * * * * * *** * * ***** * = sum + remainder;
******** * * * ** * ******** *** * ** * * /= 10;
* *** * * * ****** * **** ** * *** * * ** * *


** ***** * * ** * * **** *
* * * ** * *** * ** *** ** %d", count, sum);
}
answered by (-140 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main(){
*** * ** * * * * ***** * ** * ** i;
* * * * * ******** ** sum=0,counter=0;
* * * * ** * ***** * * * * ** ** *** **** ** ** ** * * ){
** *** ** *** * * * *** * ** * ** ******* * **
*** ** ** ** * ** **** * * ***** * * * ****
* ** * ***** * ** * *
* ** ** *** *** **** ** * **** * %d",counter,sum);
** * * * * * * * * * 0;
}
answered by (-116 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main(){
* ** * ** ** * * ** ** i;
* ** *** * *** *** * * * * sum=0,counter=0
* * * * * * *** * ** ** ** * ** ** * ** ** * ){
* * *** *** ** * ** ** **** * *** * **** * ** * * * *
* * * *** * * * * * * ** * ***** *** *
* * * **** ****
** * ** ** * ***** ** **** * ** **** %d",counter,sum);
**** ** * * * ** *** * 0;
}
answered by (-116 points)
0 0
prog.c: In function 'main':
prog.c:5:5: error: expected ',' or ';' before 'while'
     while( scanf("%1d",&i)!=EOF ){
     ^~~~~
prog.c:3:9: error: unused variable 'i' [-Werror=unused-variable]
     int i;
         ^
cc1: all warnings being treated as errors
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
* * ** * * ***** a,sum,b;
* *** * * ** * * **** * * * * * * * **
* *** * **** * ***** * * *** ******* * **
* *** * ** * ** * ** ***** *
* ********** * ** ** * * *** ** ******** * * *
* * **** * * ** * * * **** * * ** * * **
* * *** ** ** * ** * ** * * ** * * * *
* * * **** * * * *** if(a<=99&&a>9)
******** * * * ** * * ***** ** *** * * * * *
** *** * *** *** ** *
* * * * ** * ** * **** * ***** ***** * ****** ****
*** * * *** * * **** * ** %d",b,sum);
*** *** *** ** *** ** ** ** 0;
}
answered by (-258 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.71.254.23
©2016-2024

Related questions

0 like 0 dislike
69 answers
[Exercise] Coding (C) - asked Oct 26, 2017 in Chapter 6: Loops by semicolon (5.2k points)
ID: 28913 - Available when: 2017-10-26 18:00 - Due to: Unlimited
| 2k views
2 like 0 dislike
64 answers
[Exercise] Coding (C) - asked Oct 19, 2017 in Chapter 4: Expressions by thopd (12.1k points)
ID: 27669 - Available when: Unlimited - Due to: Unlimited
| 2.6k views
12,783 questions
183,443 answers
172,219 comments
4,824 users