1 like 0 dislike
4.4k views
請設計一程式,由使用者輸入N個數字,求這些數字的平均。使用者輸入的第一個數字N代表接下來會有多少個數字要求平均,接下來的N個數字就是需要計算平均的數。輸出請輸出到小數點後六位。

sample input:

10 1 2 3 4 5 6 7 8 9 10

sample output:

5.500000
[Exercise] Coding (C) - asked in 2016-1 程式設計(一)AC by (18k points)
ID: 15378 - Available when: 2016-10-27 18:30:00 - Due to: 2016-10-27 21:00:00

edited by | 4.4k views
0 1
Called for Help
0 0
#include <stdio.h>
#include <stdlib.h>

int main()

{
    int a,n;
    float c;
    scanf("%d",&a);
    int b[a];
    for(n=0;n<a;n++)
    {
        scanf("%d",&b[n]);
    }
    for(n=0;n<a;n++)
    {
        c=c+b[n];
    }
    printf("%.6f",c/a);
    return 0;
}

102 Answers

0 like 0 dislike
Hidden content!
int main()

{
* * * ** ** a;
* * * *** * * * * ** * ** ** *** **

   int num[a],i;
* ** * * *** *** ** * *** **** **
** * ** * * * ** * **** ** * **** * ****** * * *
* ** * *** * * **** * sum,ave;


******* ** * ****** * ** * ***
** ** * **** * * * ** ** ******

ave=sum/a;
* * *** *** **** ** **

}
answered by (-124 points)
0 like 0 dislike
Hidden content!
#include <stdio.h>



int main()

{
* * * ** *** * ** * * N;
** * ** *** * * * ** *** *** *
* * * ** ** ******** num[N],i;
** * * * * * * * * * *** ave,sum=0;
* * * * *** * * (i=0; i<N; i++)
* * ** *** ** * * ****
** * * * * ** **** * ****** * *** ** ** * **** * * * * * ***
* * ** *** * ***
* *** ** * ** * * * (i=0; i<N; i++)
*** * *** *** * * **** ** * *
* ** ** ** * *** *** * * * * * * = sum + num[i];
** * * * ** ** * *** ***
*** * ********* = sum / N;
* * * ** * * ****** ** * ** ***** **** ** *



}
answered by (-162 points)
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.69.59.90
©2016-2024

Related questions

0 like 0 dislike
0 answers
[Resource] asked Oct 27, 2016 in 2016-1 程式設計(一)AC by Shun-Po (18k points)
ID: 15475 - Available when: Unlimited - Due to: Unlimited
| 13 views
0 like 0 dislike
5 answers
[Exercise] Coding (C) - asked Oct 27, 2016 in 2016-1 程式設計(一)AC by Shun-Po (18k points)
ID: 15447 - Available when: 2016-10-27 18:30:00 - Due to: 2016-10-27 21:00:00
| 499 views
1 like 0 dislike
37 answers
[Exercise] Coding (C) - asked Oct 27, 2016 in 2016-1 程式設計(一)AC by Shun-Po (18k points)
ID: 15446 - Available when: 2016-10-27 18:30:00 - Due to: 2016-10-27 21:00:00
| 1.6k views
1 like 0 dislike
17 answers
[Exercise] Coding (C) - asked Oct 27, 2016 in 2016-1 程式設計(一)AC by Shun-Po (18k points)
ID: 15442 - Available when: 2016-10-27 18:30:00 - Due to: 2016-10-27 21:00:00
| 958 views
1 like 0 dislike
18 answers
[Exercise] Coding (C) - asked Oct 27, 2016 in 2016-1 程式設計(一)AC by Shun-Po (18k points)
ID: 15440 - Available when: 2016-10-27 18:30:00 - Due to: 2016-10-27 21:00:00
| 980 views
12,783 questions
183,443 answers
172,219 comments
4,824 users