1 like 1 dislike
3.4k views

Write a program that get the input of two integers n and m(n < m). Find out all prime numbers between n and m (not include n and m), then display them on the screen.

寫一個程式 輸入兩個整數n和m (n < m),找出所有n到m之間的質數(不包含n和m)。

Example input 1

1 10

Example output 1

2 3 5 7

 

Example input 2

10 20

Example output 2

11 13 17 19

 

[Exam] asked in Midterm by (12.1k points)
ID: 32708 - Available when: 2017-11-15 14:10 - Due to: Unlimited
2 flags | 3.4k views

45 Answers

0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
    int n,m,i,j,c=0;
    scanf("%d %d",&n,&m);
    for(i=n+1;i<m;i++){
** ** * * * **** * **** * ** *** * * * ** * ****
* * ** * ** ** * *** ** ** ** * * * * ** ** * ** ***** ** *** * ** *
* * * * ** * * ** ** ******* *** ** **** *** * * * *** * * * ** * **** * ** ** *
** ** ** * *** ** **** * ** ***** * * *** * ***** * ** ****** ***** * ****** * ** ** * *** * * ** * * * * * *
** * * ***** * ******* ** * ** * ** ** ** * ** ** * * * * ***** * * ** ** * ****** ***** *** * * *** * *** * *
** * *** ** * ** * ** * * *** * * *** * * * ****** * * * ***** * *
* * * ** ****** ** *** ** ** ****** * * * * * * * * ** * **** ** * ** ** ******** * *
* ** ** * * * ** *** **** ** * ** * *** *** * * * * * ** ******** * ** * * ****** * * * *** ****** * %d",i);
* *** *** ** ** **** *** ** * * ** * ** *** **** * * ** *** * * * * * ******
* **** * * * *** ** * ** * * ** ** * * ** * **
** *** ** * ** * ** ** * * * * ** * * **** * **** if(i%j==0){
** * * * * * * ********* ** * ***** * ** * ** * **** *** ** ** *** * * * *
* *** * *** * * ** * *** * * * * *** ** * ** ** **** * * * *** *
        }
    }
    return 0;
}
answered by (54 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main()
{
    int n1,n2,i,c=0;
    scanf("%d %d",&n1,&n2);

    for(i=n1+1;i<n2;i++)
    {
        int a;
** * ** * *** * * * ** * ** ** ***** ** * *****

** * * * * **** * * * ** **** * * * *** **
** ** ** * ** * * ** * * **** ** * *** * * * * * * *
* *** * * * *** * * *** * ** * * ** ** ***** ** * **
** * * ** * * *********** ** * * ** ** * ** * **** * * ** **** * *
* * ** *** ** * * * * * ** ** * * * * ** * ***
**** * * ** * ******* * **** ** * **** ** ** ** *** * ** ********* * *
* ***** ** * * **** ** ******* *** * * * * * *** *** ** * ** **** * ** * * **
* * ** *** *** * * *** ** * * * * ***** * ***** * ** ** ** ***** * * *** **
* ** * *** * ** ** * * *** *** * ** * * * ** * ** * * ** **** * * * ***** * ****** * * *** * * * ***
** * *** * ** * ***** * ****** ** **** * ** * * ** ** **** * ** * * * * *
* * * ** ** **** * **** *** ***** ***** **** * **** ** * ** * ** ** ** **** *** *
* * **** * ** * * *** ******* ***** * * ** * ***** * ** * **** * * ** ** *** *** * *
* * ** **** * *** * * * *** ** ** * * ** * * *** ** **** **** **** *** ** * * * *** * ***
* * *** ****** *** *** ** * ** * ****** ** ** ** *** * ****** ** * * *** * *** * * ** * ** * *** *** *** * * *** * * %d",i);
* * * ** * * * ** *** *** ** ** * *** ** * ***** * * **** * ** * ***** ** * * * *
** * *** * ***** * **** ** ** *** * ****** ***** * * * * ** ** *
    }
    return 0;
}
answered by (-323 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main()
{
    int n,m,d;
** * * * * *** * ** * ** ** *** %d",&n,&m);
    n++;

    do{
* **** * * **** * * * ** * * ** * * ** * * *** ****** ****
*** * ******** * ** * * ** **** * ** ** * * * ***** *** * ****** * * *
* ** * ** ** * * * * ***** * * ** * *** * * * * *** **** ** ** *** *
* * * *** **** * ** **** ** ** *** ** * * **
* *** * ****** * ** **** * *** ** ** * ** ** * *** * * *** *** *
* * ****** ** * ***** ** ******** * ****
* * * * ** ** ***** ** **

    while(n<m)
* *** * * ** * * * ** **** ** ** * ** ** * * ** * * **
****** * * * * * * * ** ** ** ** **** ** ***** * * ***** * *** **
** * * **** *** * * * ** ****** ** * ** * * *** **** **** ** * * ** *
** ** ** ** * * **** * * ** * *** ***** *
**** ** * * * ** ** * ** ** * * *** *** * * *** * **** ** * * ** * * * ** %d",d);
** * * * ** ** ** *** ** ** ** * * **** **** * *
* *** * ** *** * ** *** * * * ** * * * * 0;
}
answered by (-196 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a,b,i,j,prime = 1,cnt = 0;
* ** * ***** **** ** * ** * ** * %d",&a,&b);
* ** ** * ***** * * * * * * = a+1 ; i < b ; i++)
    {
** ***** * *** *** * * *** * * * * ************ ** * = 1;
* *** *** * * * *** * ** ** *** * ** * * ***** = 2 ; j < i ; j++)
** * * * * ***** * ****** * **
** **** ** *** *** * ** **** *** ** ** * ** ** * * ** * * % j == 0)
* ** * *** * ** ** **** ** * **** ** * * ***** * ** * **** *** ******* * ** ** * ***** **** ** = 0;
* * * * ** * * * **** ** ***** * * * * ***
** * * * * * * * ** **** * ** *** * ** ** * == 1)
*** ******* **** * * * ** *** *** *
**** **** * ***** *** **** ** ********** * *** **** **** ** ** * * * *
* ** ******* ** ** * * * ** * *** * * * ****** *** *** *** == 1)
* * ***** *** *** **** * * * *** ** * *** ** * ** * ** *** ** ** ***** * ** *** *** *** *** *****
* ** ** * *** * ** ** **** **** ****** ** ** **** ** ** ** *
* * * *** * *** * * * ** * *** *** * ** * **** * ** * ** ** * **** ** * * * * * %d",i);
*** * * **** *** * **** * * * * ** * * ****
    }

*** * * *** * ** * * * ** * 0;
}
answered by (-255 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>

int main(){

    int a,b,c=0,i,j;

* * ** * * * *** * * *** * * * ** * ** **
    for(i=a+1;i<b;i++){
** * * ** * * ** ** * * ** * * * **** * * * ** ** *
*** * * * * **** ***** ******* ** ***** * ** **** * **** * **
*** *** * **** * * * **** * * * ** *** ********* * * **** *** * * ** * * * * **
* * ***** * * *** * *** * ** * * * * * **** * * ** * ** * ** * ** * ** * ** ****** *** * ** * * ** ** * ** ** * * * * * ** * ***** **
* * * ** ** * ** ** * * *** ** * ** **** * * * * ** * ****** * **** * *** * * ** ** * * ** ** * * *** *** * **
******** ***** * *** * * * ** * ** * ** ** * * * *********** ** ** * * ***** * ** * ** ** * * * ** * ** *
* ** * * ** ** *** * *** ****** * ***** *** * ** ** * * * * ***** * * *** * *** ** * ** printf(" %d",i);
* * *** ** * ** ** * ********* * * *** ** * **** *** * * * **
* * * * * * ** ** ** ******* ** ** * **** ** ** ***** * * if(i%j==0)
** ** * * **** * ** * * ** *** * ** ** ** ***** *** * *** *** * **** * **** ***
        }
    }



return 0;
}
answered by (-301 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.179.72
©2016-2024

Related questions

0 like 0 dislike
22 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36753 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 2.1k views
0 like 0 dislike
99 answers
[Exercise] Coding (C) - asked Nov 2, 2017 in Chapter 6: Loops by semicolon (5.2k points)
ID: 29829 - Available when: 2017-11-02 18:00 - Due to: Unlimited
| 7.6k views
0 like 0 dislike
21 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36754 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 2k views
0 like 0 dislike
10 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36752 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 1.2k views
12,783 questions
183,443 answers
172,219 comments
4,824 users