3 like 0 dislike
3k views

Write a program that reads the number of students who passed and failed in the exams and displays the percentages. For example:

輸入及格與不及格人數
輸出及格與不及格百分數

Example input:

12 8

Example output:

Success Ratio: 60%
Fail Ratio: 40%
[Exercise] Coding (C) - asked in Chapter 4: Expressions by (12.1k points)
ID: 25730 - Available when: Unlimited - Due to: Unlimited

edited by | 3k views

86 Answers

0 like 0 dislike
Hidden content!
* * ** ** ** **

int main(void){

* * ** *** * ***** **** a,b;

*** * ***** * * * *** ******* * *** * ** * * *
*** * ** * * *** ** * *** ** * ** *** ** ***




* * ***** * *** ** *** * * * Ratio: * ** * **
** *** * * ** * ** * * * Ratio: %.0f%%",b/(a+b)*100);

*** **** * *** ** * ** * * * 0;




}
answered by (-301 points)
0 0
prog.c: In function 'main':
prog.c:7:13: error: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Werror=format=]
     scanf("%d",&a);
             ^
prog.c:8:13: error: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Werror=format=]
     scanf("%d",&b);
             ^
cc1: all warnings being treated as errors
0 like 0 dislike
Hidden content!
#include<stdio.h>



int main(void){


*** ** * * * * * * **** ** a,b;


** * *** *** * * *** ** * * * **** *** *** ** * **
* * *** * * * * * ****** ** * *** ** * * **** *








* *** ** ** ** ** ** * * ****** * ********* *** ***
* * ** *** * *** * *** ** ***** ** * ** ** * * *


** * **** *** ***** * 0;









}
answered by (-301 points)
0 like 0 dislike
Hidden content!
* * * ***
*** * ******** ****

int main()
{
* * * * * *** * ** *** * passed = 0;

** *** ** ** ****** *** failed = 0;

* ** * * * * ******** * a = 0;

* * **** * ** * ** ** b = 0;

** ** **** * *** * * * *** **** * **** **

* * * * ** *** * * * * ** * * ** * * ***

** ** *** ** * ***** ** * = passed / ( + * * ) * 100;

** *** ** ** * = ** / ( passed + failed ) * 100;

* ** *** * ** ** * * * * * Ratio: **** ** ** a);

* * ** *** * ****** * * * Ratio: * * * b);

** * ******* * ** ** ** 0;
}
answered by (-285 points)
0 1
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
**** ** ***** ***
int main()
{
** *** * * *** **** * * *** ***
* ** ** * ** *** ** * **** * %d * **** ** ** ** **
** * * * *** ** ** *** * ** ** = a*100/(a+b);
* ** ** * ** **** * * ** ** = b*100/(a+b);
* * ** ** * ** * ** * ** * * * * Ratio: ** * * * * *
* * ***** * ** * * *** * * Ratio: %d%%",failRatio);
* *** *** * * * * * 0;
}
answered by (-281 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
* *** **** * *

int main()

{
** * * * * * ** * ** * **** * ** ** ***
* * *** * ** * ****** * * * * * %d * * ** ****** **
****** * * * ** **** * *** * * = a*100/(a+b);
* *** * *** * ** *** ** = b*100/(a+b);
** * * ** * *** * *** * Ratio: ***
* **** ** ** * * *** * ******* Ratio: %d%%",failedRatio);
* * *** **** **** * **** ** 0;

}
answered by (-281 points)
0 like 0 dislike
Hidden content!
#include <stdio.h>



int main(void)

{
* *** * ***** * ** * a,b,sum1,sum2;
**** ** * ** *** * * ** ** * * ** ** * *** *
** * *** * ** *** * *** = a*5;
* ** * ** * ******** * **** = b*5;
** * ** * * * *** ** (sum1>40)
** ** * * *** **** * * * * ** * *** **** * ***** ** * Ratio: %d%%\n",sum1);
***** ** * ** * * **
* * * * ******** *** **** * *** * * * * * *** * * * * Ratio: %d%%\n",sum1);
** * ** * * ** * *** * ** **
*** ** ** *** ***** * *** * *** * * * ** * Ratio: ** *** ** ** *
** * *** ** ****** * ***
* *** ******* * * * * * * * *** *** * * * *** * Ratio: %d%%\n",sum2);
* * ** ** ** *** ** **** 0;



}
answered by (-323 points)
0 like 0 dislike
Hidden content!
#include ** * **** ****
#include * * * ** * *** **

int main()
{
* ** *** *** **** ** ** a,b;
******* * * *** *** * c,d;
* ***** *** * ** ******** * * ** * * ****
** * *** * * ** * *** ** ****
** * *** ** * **** * **** *
* ** * ** * ***** * * * ** * *** ** Ratio: %d%%\nFail Ratio: %d%%",c,d);
**** ***** * ** *** * * 0;
}
answered by (-258 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>

#include ** *** * *



int main()

{
** * ** ** * * *** ** ** * * a,b;
* ** *** * * * *** ** * c,d;
** ** ** * ** ** * * * * * * ** * * * * *** **
***** * ** ** *** * ** *
** * * ** *** *** ** * * *
* * ** * **** *** **** * * * * *** * %d%%",c,d);
*** * *** * * * * * * * 0;

}
answered by (-258 points)
0 like 0 dislike
Hidden content!
#include <stdio.h>



main(void)

{
* * * *** ** a,b,sum1,sum2;
** ** * * * * * * * * ** *** ** * *** * * *
** *** * ** * * *** * = a*5;
** * ** ** * **** ****** = b*5;
** ***** *** ** ***** (sum1>40)
* ****** ** * * ** *** * * **** *** * ** * * * *** * *** * ** Ratio: %d%%\n",sum1);
* ** * *** * * * *
* * * * ****** * * * * ** *** * ** ** * * **** * * Ratio: %d%%\n",sum1);
** * *** * * ** *
* ***** * ** ** **** ** ** **** *** *** ** * ** * Ratio: * ******
* * * * * * * ** ***** **
*** *** *** ** ******* * *** * ** ***** * * * **** **** Ratio: %d%%\n",sum2);
** ** * * ** *** ** ** 0;



}
answered by (-323 points)
0 like 0 dislike
Hidden content!
#include * * ** *
#include * **** ****
int good=0,bad=0;
int main()
{
** * * * * ** * **** *** *** ** ** **

* ***** *** *** ***** ** ** * ** Ratio: * **** ** * *** ***
* * ** * ** * **** ** * * * ** Ratio: ** ************** * *
*** ** ** ** * *** * 0;
}
answered by (-286 points)
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.71.254.9
©2016-2024

No related questions found

12,783 questions
183,443 answers
172,219 comments
4,824 users