3 thích 0 k thích
5.6k đã xem

Write a program that reads the number of students who passed and failed in the exams and displays the percentages. For example:

輸入及格與不及格人數
輸出及格與不及格百分數

Example input:

12 8

Example output:

Success Ratio: 60%
Fail Ratio: 40%
[Exercise] Coding (C) - đã hỏi trong Chapter 4: Expressions bởi (12.1k điểm)
ID: 25730 - Xem được từ: Không giới hạn - Hiệu lực đến: Không giới hạn

đã sửa bởi | 5.6k đã xem

86 Trả lời

0 thích 0 k thích
Hidden content!
#include * *** * *** **
int main ()
{

***** * ** * ** ***** * ** pass, fail;
* * * ** * * * ** * *** ******
*** **** ** * **** * * * ** ***** * &pass, ** * **

* *** ** * ** ** *** = ** **** ** * ;
*** ** * ** * ** * ** * = * * ***
* * *** * **** ** ** * ***** Ratio: ** ** *** passratio);

** ******** ** * * ** * ** * ** Ratio: * * ** ** failratio);
return 0;
}
trả lời bởi (-167 điểm)
0 0
Case 0: Correct output
Case 1: Correct output
0 thích 0 k thích
Hidden content!
#include * ***** ** **
int main ()
{

* ** ** ****** * ** * * * pass, fail;
* * **** * ** * ** ** ** *** ****
* * ** ** ***** ** * * ** * ** * &pass, * * **

* ** ** * * * ** * * = * * ***** * ;
* * * * * ** * * ** **** ** ** *** = * * * **
* * * *** * ** *** *********** Ratio: * * ** * passratio);

**** ** * * *** **** ** *** * Ratio: ** * * failratio);
return 0;
}
trả lời bởi (-167 điểm)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 thích 0 k thích
Hidden content!
#include ****** ** ** *
int main ()
{

******** **** * *** * ** pass, fail;
* * **** ** *** * *** **** ** ** *
**** *** * * ** ***** * * *** * ** ** &pass, * * *

*********** * *** *** = * * * ** ;
** ** ***** ********** * = ** ** * ***
** ****** * *** * ** * ** Ratio: ** *** * * * passratio);

* **** * * ** ** *** ** ** ** **** ** Ratio: **** * *** * *** failratio);
* ** * 0;
}
trả lời bởi (-167 điểm)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 thích 0 k thích
Hidden content!
#include ** ** ** *
int main ()
{

* * **** ****** ** pass, fail;
** ** * * * * * ******* * * *** * * **
**** **** ***** * *** ** ** * * * **** ** * &pass, * ** *

** * * ** *** * ** = * *** * ** ;
* * * *** ***** ****** * = * ** *
** * * ** ******* ** ** ** ** **** ** * Ratio: * *** * * ** passratio);

* * ***** * ** ** * * ** * * * *** Ratio: * *** * failratio);
return 0;
}
trả lời bởi (-167 điểm)
0 0
prog.c: In function 'main':
prog.c:11:32: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("Success Ratio:  %d%\n", passratio);
                                ^
prog.c:13:28: warning: spurious trailing '%' in format [-Wformat=]
     printf("Fail Ratio:  %d%", failratio);
                            ^
0 thích 0 k thích
Hidden content!
** **** *** ***
int main(void)
{
** * * ** * * * a, a1,b,b1;
**** ** *** * ** * * * ***** * * **
* ** **** ** * * ******** ***
* * ** **** * *** * * ****
* * * *** * * ** ** * * * Ratio: ** * * *
**** * **** *** *** * * **** Ratio: %g%%",b1);
** * ***** **** * * 0;
}
trả lời bởi (-254 điểm)
0 0
Case 0: Correct output
Case 1: Correct output
0 thích 0 k thích
Hidden content!
* * * ** ** ***
int
int ** ** p1,p2;
** **** * ****** **** * ** ** * *
** * ****
** ****
*** * Ratio: ** ** Ratio: ** * * * *
* 0;}
trả lời bởi (-32 điểm)
0 0
Case 0: Correct output
Case 1: Correct output
0 thích 0 k thích
Hidden content!
** * ** * * *
int main()
{
float a,b,c;
*** ** ****** ** *** * * * *** *** * *** **** *
**** * * *** ** *
** ** * ** * *** * * ** Ratio: * ** * ** **
** * * ** ** * ***** ** Ratio: %.0f%%",b/c*100);
** * * ** * 0;
}
trả lời bởi (64 điểm)
0 0
Case 0: Correct output
Case 1: Correct output
0 thích 0 k thích
Hidden content!
#include <stdio.h>
int main ()
{
* ** * * ** * *** * * a,b,c;
** * * **** *** * * *** * * * *** *
* * * **** ** ** * * *
*** * *** ** ** * ** * * ** * * * * Ratio: ** ** ** * *
*** ***** * * * ** *** * * ** *** Ratio: * *** * ***
*** * ******* * * *** ****** 0;
}
trả lời bởi (54 điểm)
0 0
Case 0: Correct output
Case 1: Correct output
0 thích 0 k thích
Hidden content!
#include <stdio.h>
int main ()
{
* * * ** * * * * ** ** * ** * a,b,c;
* ** ** * * * * ** **** ** ***** *** ** * **** * ** **
* * * * ** *** ****** * * *
** * ** * ** * **** ** * ** Ratio: ** ****** ** **
* ** ** * * * ****** **** **** Ratio: ** *** **
* * ******* *** ** * * 0;
}
trả lời bởi (54 điểm)
0 0
prog.c: In function 'main':
prog.c:5:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Wformat=]
     scanf("%d %d",&a,&b);
             ^
prog.c:5:16: warning: format '%d' expects argument of type 'int *', but argument 3 has type 'float *' [-Wformat=]
     scanf("%d %d",&a,&b);
                ^
0 thích 0 k thích
Hidden content!
* * * * *******

int main()

{
*** *** ** * * **** ** a,b,c,d;
***** ******* *** **** ** * * * **** * *****
** * *** *** * * * * * * **** *** * ** * ****

* * * ** *** * * *** * ********
* ** ** *** * *** *** ** **

* * * * * ******* ** * * ** Ratio: %.f%%\n",c);
* * ** ***** * *** * ** * ** Ratio: %.f%%",d);
* **** * **** ** * * * *

* * * *** * *** *** 0;
}
trả lời bởi (-32 điểm)
đã sửa bởi
0 0
prog.c:3:1: warning: return type defaults to 'int' [-Wimplicit-int]
 main(void)
 ^~~~
0 0
prog.c:3:1: warning: return type defaults to 'int' [-Wimplicit-int]
 main()
 ^~~~
0 0
Case 0: Correct output
Case 1: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.178.237
©2016-2024

Không tìm thấy câu hỏi liên quan

12,783 câu hỏi
183,443 trả lời
172,219 bình luận
4,824 thành viên