3 like 0 dislike
5.6k views

Write a program that reads the number of students who passed and failed in the exams and displays the percentages. For example:

輸入及格與不及格人數
輸出及格與不及格百分數

Example input:

12 8

Example output:

Success Ratio: 60%
Fail Ratio: 40%
[Exercise] Coding (C) - asked in Chapter 4: Expressions by (12.1k points)
ID: 25730 - Available when: Unlimited - Due to: Unlimited

edited by | 5.6k views

86 Answers

0 like 0 dislike
Hidden content!
#include <stdio.h>
#include * * * ** ***

int main()
{
* * ******* * ** * a,b;
* * *** *** ** * * * * ** ** * * ** ********** *
* **** ** ***** * * * ** * Ratio: ** ** * ******
** **** **** * ** * * * Ratio: * *** ** * *
** * * *** ** * ***** ** 0;
}
answered by (-108 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main(void)
{
** ** ** * ****** * * * * *** a,b;
* * ** ** * * * c,d;
* **** ** * * ***
* ** * * * **** ** * *** * * **** * * ** * ***
* * ***** * * *** * ** * **
* ** ** ** * * *** * *** * ****
* * ** ***** * * * *** * * **** Ratio: %.f%%\n",c);
* **** * ** ******* * ** ** * Ratio: %.f%%",d);
** **** ** ** ** *
** *** * * **** * * *** 0;
* *** * * * ** * *
}
answered by (-127 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>



int main(void)

{
*** ** *** ** ***** ***** a,b;
* ** *** * * * * c,d;
* * * * ** * * * ***
*** * * * ** * ** * * * * * * ** *
** * *** * * * * * ** * * ****
* ** * * * * ***** * * ** * *
* * * * * **** * * ** ** * * *** * Ratio: %.2f%%\n",c);
* * * * ** * * **** **** ** ** Ratio: %.2f%%",d);
** * **** *** **** ****** * *
* * * * ** ** ** ** * * 0;
**** * * * * * **** ***

}
answered by (-127 points)
0 like 0 dislike
Hidden content!
#include <stdio.h>



int main(void)

{
**** * * ** ** *** * a,b;
* **** *** **** *** * ** c,d;
*** *** ** ** * * * *
** * * *** *** * ** * **** ** *** **** * ***** *
** ****** ** *** **** * ** * ***
*** * **** * ** *** ** ** *** ** *
* ** * * *** *** * * **** * *** %.2f%%",c,d);
** ** ** * ** * ***** **
* * *** * * * ** * * * 0;
* * * * ** * ** * ** ** *

}
answered by (-127 points)
0 like 0 dislike
Hidden content!
* ** * * * *
int **

{

int a,b;
** c;
* ** * *

* ** *** **
*

***** *** * **** * * *
*
* * * 100;
* * - good;

**** * ** ** ** c)
*** ** * * *** ** d)*/

* **** * *** **** ** * *** ** * **
***** *** ** * * * ** *


}
answered by (-249 points)
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
*** ** ** ***

int **



{



int a,b;
* * c;
* ** * *


*** * **
*** *


* * * * * *** *** ** * * *
*
** * * 100;
*** - *


* ** ** *** * * c)
***** *** * d)*/


** *** **** * * ** ** **** **** * ** *
* *** * ** %0.0f * **** *





}
answered by (-249 points)
0 like 0 dislike
Hidden content!
#include ** *** * ** *
 int main ()
{
** ** ***** **** a,b,c,d;
* ** * * * * ********* * **** ** * ** *** *
** * ***** ** ** ***** *
** * * * * * * ** *** * * * * ** *
****** * *** ** ***** ** * ** Ratio: ** *** *
**** * * ** * ********* * * * * Ratio: %g%%",d);

***** * ** *** **** * *** 0;



}
answered by (-254 points)
0 0
prog.c: In function 'main':
prog.c:5:13: error: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Werror=format=]
     scanf("%d %d",&a,&b);
             ^
prog.c:5:16: error: format '%d' expects argument of type 'int *', but argument 3 has type 'float *' [-Werror=format=]
     scanf("%d %d",&a,&b);
                ^
cc1: all warnings being treated as errors
0 like 0 dislike
Hidden content!
#include ** **** *

main ()

{
***** * * * ** ** ** * ** a,b,c,d;
*** * * * * *** *** ** * * *** * ** * ** * * ***
*** ***** ** * * *** * ******** *** *
* *** * ** * ** ** ** * **
* *** **** * ** ** * *** * ** ** * Ratio: %g%%\n",c);
* ********* ***** ** * * ** ** * Ratio: %g%%",d);


* * * * ** * * ** ** 0;







}
answered by (-254 points)
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include ** ***** ***** *

int main()
{
**** ** ** * ** * ** * a,b;
** * ** *** * * *** * * **** * *** ********** * * ** ** *
* **** ** * ** ** * * * ****** Ratio: *********** * ** *
* ** * *** **** * ***** **** ** * Ratio: *** ** * ****
*** * **** *** ** * *** * * 0;
}
answered by (-498 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include ** * * *** * *

int main(void)
{
** * ** * * * ** a,b,c,x,y;
**** ** ** *** ** * **** * * * *** * ******* **
** * ** ****** ** * ***** *
* *** * * * **** ***** * ** ** **
* ** * * * * ** * * **
* ** * * *** *** * *** * *** * * Ratio: %d%%\n",x);
****** ** **** * * ***** Ratio: %d%%\n",y);

** *** ** **** **** * **** 0;
}
answered by (42 points)
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.69.7.35
©2016-2024

No related questions found

12,783 questions
183,443 answers
172,219 comments
4,824 users