Toggle navigation
Courses
Questions
Tags
Users
AC 20161027 期中考 1
1
like
0
dislike
7.1k
views
請設計一程式,由使用者輸入N個數字,求這些數字的平均。使用者輸入的第一個數字N代表接下來會有多少個數字要求平均,接下來的N個數字就是需要計算平均的數。輸出請輸出到小數點後六位。
sample input:
10 1 2 3 4 5 6 7 8 9 10
sample output:
5.500000
[Exercise]
Coding (C)
-
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15378 -
Available when:
2016-10-27 18:30:00
-
Due to:
2016-10-27 21:00:00
edited
Oct 27, 2016
by
Shun-Po
|
7.1k
views
comment
0
1
Called for Help
0
0
#include <stdio.h>
#include <stdlib.h>
int main()
{
int a,n;
float c;
scanf("%d",&a);
int b[a];
for(n=0;n<a;n++)
{
scanf("%d",&b[n]);
}
for(n=0;n<a;n++)
{
c=c+b[n];
}
printf("%.6f",c/a);
return 0;
}
Please
log in
or
register
to add a comment.
102
Answers
0
like
0
dislike
Hidden content!
#include<stdio.h>
#include<stdlib.h>
int main()
{
** * * *** * * ** ** ** * num,average=0,sum=0,i,j,t;
* ** * *** * * * * ** *** * * * * * **** *
** * * * *** ** * * **** * ***
*** ** * ** * **** ** **** *** *** numin[i];
**** * ** *** ** ***** * * *** * * ***** * * * *** * * *** * ***
* *** * * * * * **** * * ** ** * += numin[i];
** ******* * * * ** *
* * * * ***** * * *** * ** * ***
*** **** * * ** * **** * * ** * * 0;
}
answered
Oct 27, 2016
by
loyfree0706
(
-216
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
* ** * * ** ** *
* ** ** *** ***
main()
{ int num=0,i,a;
* * * ** * * * ***** * * *** &a);
* * * * * ** * ** * ** ***
** ** *** ** * * ** ** ***** *
* *** ** **** *** * * *** ***** **** *
**** ** * **** *** * 0;
}
answered
Oct 27, 2016
by
李奕叡
(
-143
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
**** *** ** ** *
* *** *** ******
int main()
{
* * *** *** *** * * ** num=0,i,a;
** ** *** * * *** **** *** * ** **** &a);
* * * ** **** * * * ***
* * ** * * * * * * * ***
* * ******* *** ** * *** ******* ********* * *
* ** * ** * ** ** 0;
}
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
#include<stdio.h>
* **** ** ** * **
main()
{
* *** * ***** * * ** * num=0,i,a;
* * * ** * * * * ** ***** ** &a);
* ***** ** ** * ** ** * *
* * * * * *** * * ***
* * *** * ** ** * * ** *** * **
* ** * *** ** ** 0;
}
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
** * **** * *** **
* * ** ** ** **
* ** ** * * *
* * * * *
*
* * ** d = * = *
* *** *** **** *** **
* *
**** = * ** ** ** * ** ** *** ** **
* * = ** * * = c + *
* = c / *
* * *** *
*
*
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
#include<stdio.h>
***** * *** * ** * * *
main()
{
** * ** *** *** num=0,i,a;
* ** ** * * ** ** ** ** * * * * &a);
* * * **** *** * ** * ** ** ***
** ** * * * *** **** *
** ***** * *** * * *********** * * * **** *
**** * * * * * ** 0;
}
answered
Oct 27, 2016
by
李奕叡
(
-143
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
** * * ** * * *
********* ** * **** ** *
int main()
{
** ** ** ** i,j,a = 0,b;
** *** ** * * * ** * *** * ** * * *
* * ** * **** = 0;j < i + 1;j++)
** ** * *
* * * * * * ** * * **** ** * * * ** ** * *
* ** ** * ** * * = a + j;
* * * * *
*** * * **** = a / i;
** ** * ***** * * **** **** *
** * * ** * 0;
}
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
#include <stdio.h>
int main()
{
* ** **** * a;
* * ** ** * *** * ***** ** ** *
** ** * num[a],i;
** **** * *** * * * * *** * **** *** *
* * ** *** ** * * *** * * ** ** * ** * * **
* * *** *** * * * sum,ave;
* * ** * * ** ** * * * * ** * **
**** **** * ** *** * ****** ** *
ave=sum/a;
** * ** ***** **
}
answered
Oct 27, 2016
by
410425016
(
-124
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
** **** * ** ** ****
* * ***** ******
*****
**** d = * * =
***** * *** **** * ** **
* **
* = *** * * ** ** *** **** * * ******
** = * * *** ** ** = c + **
= c /
*
* *** ** * ** * *
*
*
*
** **
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
0
like
0
dislike
Hidden content!
* ** ** * * *** **
** * * ** * * *
*
* ** ***
* ** * * * d = * =
** * ****** * **
* * * *
* = ** * * * ********* * ** * * * *
* * = **** * * = c + *
* = c / *
*** *** **** * *
** *
*
answered
Oct 27, 2016
by
410523022
(
-276
points)
ask related question
comment
Please
log in
or
register
to add a comment.
Page:
« prev
1
...
5
6
7
8
9
10
11
next »
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English
中文
Tiếng Việt
IP:172.69.7.178
©2016-2025
Related questions
0
like
0
dislike
0
answers
AC 20161027 期中考公告
[Resource]
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15475 -
Available when:
Unlimited
-
Due to:
Unlimited
|
13
views
0
like
0
dislike
5
answers
AC 20161027 期中考 10
[Exercise]
Coding (C)
-
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15447 -
Available when:
2016-10-27 18:30:00
-
Due to:
2016-10-27 21:00:00
|
928
views
1
like
0
dislike
37
answers
AC 20161027 期中考 9
[Exercise]
Coding (C)
-
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15446 -
Available when:
2016-10-27 18:30:00
-
Due to:
2016-10-27 21:00:00
|
3.1k
views
1
like
0
dislike
17
answers
AC 20161027 期中考 8
[Exercise]
Coding (C)
-
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15442 -
Available when:
2016-10-27 18:30:00
-
Due to:
2016-10-27 21:00:00
|
1.6k
views
1
like
0
dislike
18
answers
AC 20161027 期中考 7
[Exercise]
Coding (C)
-
asked
Oct 27, 2016
in
2016-1 程式設計(一)AC
by
Shun-Po
(
18k
points)
ID: 15440 -
Available when:
2016-10-27 18:30:00
-
Due to:
2016-10-27 21:00:00
|
1.6k
views
12,783
questions
183,442
answers
172,219
comments
4,824
users