0 like 0 dislike
3.3k views

Write a program that get the input of two integers n and m(n < m). Find out all prime numbers between n and m (not include n and m), then display them on the screen.

寫一個程式 輸入兩個整數n和m (n < m),找出所有n到m之間的質數(不包含n和m)。

Example input 1

1 10

Example output 1

2 3 5 7

 

Example input 2

10 20

Example output 2

11 13 17 19

 

[Exam] asked in Midterm by (12.1k points)
ID: 36753 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 3.3k views

22 Answers

0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a,b,i,j,prime=1,cnt=0;
* ** ** * ** ** ***** * **** * %d",&a,&b);

    for(i=a+1; i<b; i++)
    {
* ****** ***** * * * * *** ** * * ** *
* *** ******* ** * *** ** * * * *** * j<i; j++)
** * *** ** *** ********** * *** ** * *** * * **
** *** ** * * ******* ** ***** * * ** * *** * * ** * ** ******* (i%j==0)
******* * * ** * ** * * * ** ****** *** ** *** **** ** * **** *
** * ** ** ** * **** * ** *** *** * * ** ** * * *** ******** *** ***** * * *** *** * * * ****
*** ***** * *** ** *** ** * * * * * * * * ***** ***** * *** *** *** **** * ****
* * * ** * ** **** * **** **** *** * ** * * **** * *
* *** * ** * * ** ****** * * *** *** **
* * *** ** * * ****** **** ** ** * * (prime==1)
* *** * ** * * * ** ** * * * ** *** * ** *
* * ** * * ** ** * * ******* * * ** * ** * * * * *** * * * *** * ***
* * ***** * * **** *** * ** ** * *** ** * * **** * ** *** **** * * ** * ** *
* * * * * * * * * * ***** **** ** *** ****** *** ** ** * * * ** ** * ** * * *** * * **** ** *** **
* * * * **** * * **** * * * * * ******* * ***** * * * ***
* * ** *** *** *** * * ** **** ********* ** ** ** ** * ** ** ** * ***** * **** * * * * %d",i);
** *** ******** * *** ** * * ** *** ***
    }

    return 0;
}
answered by (-127 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include<stdio.h>
int main(void)
{
    int m,n;
    scanf("%d %d",&m,&n);

    int i,ip,j;
    int c=0;
    for(i=m+1;i<n;i++)
    {
** ** ** * * * * * * * * ** * ***** ******
* * *** *** ** **** ** * * * ** ** ** * **
** * ** ****** *** ** * ***** ** *** ** * ***
* ** ** * * * *** * * * ** * **** ** * ** * * *
* * * * *** * * * * * * *** ** * *** * ******** * * * *** **
* *** **** **** ** * * * ** * ** ** ** ** * * * ****** * * **** *** *** ** * * * * * ** * ***
* ** * ** *** ** *** * * *** ** * **** ** ** * * * * * *** * ** *
*********** ***** * * ** ****** * * *** * *** *
** **** ** *** ***** ** * *** * * * * * **** *
        {
** * * * *** *** * **** ** ** ** *** * * ** ** **** ** ** ******
* * ** ** ***** ** *** * * * * *** * * * *** * *
* * *** * * * *** * * ** * ** * ** ****** * **** * *
** * **** ***** * * ***** * * **** * ** ** * * * * * *** * **** * * * *** *** * * ** ***** *
** * * **** * * * *** *** * * * **** * ** ** * ** * * **
*** * * ** * *** * * * ******* ** * ******* * * * * * *** * *** * **
* ***** *** * * ** ****** **** * * *** * * * *** * * * * ****** * * *
** ***** * * * ** * ** * *** * * ** ** *** ** * * * * ******** ** * ** * ** * ** *** * * ** * %d",i);
*** ** * * ** ** * ** *** ** *** *** ** ***
* **** ** ********** * ***** ** * *
    }
}
answered by (-249 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.179.46
©2016-2025

Related questions

1 like 1 dislike
45 answers
[Exam] asked Nov 15, 2017 in Midterm by thopd (12.1k points)
ID: 32708 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 5.8k views
0 like 0 dislike
21 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36754 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 3.2k views
0 like 0 dislike
10 answers
[Exam] asked Dec 9, 2017 in Midterm by thopd (12.1k points)
ID: 36752 - Available when: 2017-11-15 14:10 - Due to: Unlimited
| 1.8k views
0 like 0 dislike
99 answers
[Exercise] Coding (C) - asked Nov 2, 2017 in Chapter 6: Loops by semicolon (5.2k points)
ID: 29829 - Available when: 2017-11-02 18:00 - Due to: Unlimited
| 12.5k views
12,783 questions
183,442 answers
172,219 comments
4,824 users