0 like 0 dislike
6.7k views

Write a program that reads integers and stores them in an array. Then, the program should rotate the elements one place to the right. For example, if the array were 1, -9, 5, 3, the rotated array would be 3, 1, -9, 5.

寫一個程式 輸入整數放在陣列裡。將陣列裡面的元素向右旋轉一次

Example input 1: First number is the element of array to input, then the list of numbers

4
1 -9 5 3

Example output 1:

3 1 -9 5

 

Example input 2:

5
2 7 9 3 12

Example output 2:

12 2 7 9 3

Please remember, you may correct the cases, but your code always be revised!

[Exercise] Coding (C) - asked in Chapter 8: Arrays by (5.2k points)
ID: 34913 - Available when: 2017-11-30 18:00 - Due to: Unlimited

edited by | 6.7k views

56 Answers

0 like 0 dislike
Hidden content!
#include<stdio.h>
//#define N 100



int main(void)
{
* ******* *** * * * ******* N,i,temp;

** * * **** * * *** **** * ** *****
* * * * * * ** a[N];
* ******* *** *** * *** * (i=0;i<=N-1;i++){
* * ** ******* * ***** * * * ** ***** * * ******** ** * * ** *
    }
*** ** *** **** ** * ***
* ** ** * ** * ** ******* * *****
****** * *** **** * * *** *** ** * ***** * ** ** *** *

****** * **** * *** ** * * ** ** * **** *** * * ****** * *
* * ** * * ** * ***
*** *** * ** * *** ** *
** ***** ** ** ******** (i=0;i<=N-1;i++){
**** **** ** ** * **** * ** ** *** ** ** * * *** * * *** ",a[i]);
** ** **** *** ** ** ***

* * * * * * * ** * * ** ***** * ** 0;
}
answered by (-167 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main()
{
* ** **** ** *** * ** n,i;
* * ***** * * ** * ** * ** *** * * * ** **
**** *** * * * ** array[n];
* * * ** *** * ** * * ** * * *
** * * * * * * * * *
* ** ****** * * ** * * * ***** ** ** *** * * * * * * ** * ** ** * * *
* * * ** * * ** **
*** ** * ******* * *** *
***** ** * *** ** ** *** * * *** **
* * ** * * ** * *
printf(" %1d",array[i]);
* ** ** ** **** ** **** ** * ** * * ** * * * * *
return 0;
}
answered by (-32 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
** * ** ******* * ** ** * i,N;
* ** ** *** ** * *** * * * ** * ** * *** ***** **
** *** ** * * ** * ** a[N];

** **** *** * * * ** * * ** (i=0;i<N;i++)
** ** ** ** * ** * ** * ** *** * * * * **** * * * ** ****** * *
** ** ** ** ** ** * * * *** ",a[N-1]);
* * * * * *** ** ** * **** * ***
    {
** ***** ** *** **** ** *** *** * ** * * **** *** * **
*** ** * * *** * *** * * * * ** ***** ** *** * * **
* * * *** * * * ** **
**** * ******* * ** * *** ** ** * ** * ** ** * * ",a[i]);
* ***** ** * * ***
* * * ** * * **** 0;
}
answered by (-284 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
* * * * * *** *
int a[100];
int b[100];
int x,i,f,p,q;
int main(){
***** * * **

* * ** ** *
{
* * * * * ****** * ** * * * *** * *** * ** **
*** *** * **** **

***** ** ** ** **
{


**** ** * * ** *
* ** * * ** * * * **** *
}
b[0]=a[x-1];

* * * ** * ** ** **
for ** *
* ******* *** ** *

}
answered by (-336 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include * * ***** * **
#include * * ** * **

int main()
{
** * * * * i,N;
** * * ** ******** ** ** * *** * *****

***** *** * * a[N];
* ** *** ** (i = 0; i < N; i++)
** ** ** ** **** * * ********* * ** ** ***
* * * **** ** ** * ** ", a[N-1]);
* ** **** ****** ** *****
** *** ** **
** ** ** *** * *** ** (i==N-2)
** ** * * *** **** *** ** * *** * * **** * * ", a[i]);
** * * ***** ** *** ***
*** *** ** * * * * ** * ** ** * ** * * * ** ** * ", a[i]);
* * *
* * * *** 0;
}
answered by (-284 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
* *** *** *** * **** * i,N;
* * **** * ********* * ** * **** * *
**** * * * * *** * *** a[N];

* * **** ** ** ** *** * (i=0;i<N;i++)
* ** *** *** * * * ** * * ****** ** *** **** ** * ** ** ** * ****** **
** ** * * * * * * ",a[N-1]);
**** ** * ** * * ** *** * *** * *
    {
**** * *** * * * * * *** ** ***** * * * *
* *** *** * ** * * ** * ****** ** ** * * ************* ****** * *
***** * ** * * **
** * * * ** ** ** * **** *** ***** * **** * * ** ",a[i]);
** ** ** ** *** ** *
** *** * * * ** ***** ** 0;
}
answered by (-108 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
** *** **** *** * *
int a[100];
int b[100];
int x,i,f,p,q;
int main(){
* *** ** *** *** ** * *

* * ** * * *
{
* ** ** ******** *** ** * ******** ***** **
**** * **** * **** * **

** *** **
{


* ** * *** * * * **
** * *** * * * **** ** ****
}
b[0]=a[x-1];

* * * * ** * **
for **** ***** * *
* * *** * * *** *

}
answered by (-336 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main()
{
* *** *** * ** * *** ** *** a,i,num[100];

* * * * * * * ****** *** * ** * ** *

* **** *** * ** * * * * * **** * * **
** * * * *** * ** *** ** * ** **** * * *** *** * ** ** *
    }

** ***** * **** ** ** **** ** * * *** ****** *

* * * ** **** ** ** ** * ** * * * * ** **
** ***** *** * *** ** ***** * *** * ***** %d",num[i]);
* ** * * * ** * *


}
answered by (-301 points)
0 0
Case 0: Correct output
Case 1: Correct output
Case 2: Correct output
Case 3: Correct output
0 like 0 dislike
Hidden content!
#include * *
#include * ********

int main()
{
*** * * ** i,N;
* * * *** ** *** ** * * * &N);

** ***** ***** a[N];
* * * * (i = 0; i < N; i++)
* ** **** * * * ** * * ** * * &a[i]);
* * * * * * ** * * ****** a[N-1]);
* ** * ** * i<N-1;i++)
** * * **
* * **** * *** ** (i==N-2)
* * **** ** ** * * * * ** *** * ** ** ** ** ********* **** *** a[i]);
**** *** * ** ***
** * * * *** **** * * ** * ** * * ******* ***** * **** * * * * a[i]);
** * ****
* ***** ** * * 0;
}
answered by (-284 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
Case 2: Wrong output
Case 3: Wrong output
0 like 0 dislike
Hidden content!
#include * * * ** **
#include ** *****

int main()
{
** * *** i,N;
****** ** *** * ** * * ** ** &N);

* ** ******* * ** a[N];
* ***** ** * * ** (i = 0; i < N; i++)
* * *** *** * * ** * * * * ** * **** ** a[i]);
** * * ** * ** *** * ** a[N-1]);
* ** * ** *** * i<N-1;i++)
** * ***** ***
* * **** * * ** * ** (i==N-2)
** **** * ** * * * * *** * * ** ** ********* ** * * * ****** a[i]);
* * ** *** ** * *****
*** * *** * *** ** ** ** **** * * *** ***** * * a[i]);
* *** * *** *
** *** **** ** * 0;
}
answered by (-284 points)
0 0
prog.c: In function 'main':
prog.c:11:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'int' [-Wformat=]
     scanf("%d", a[i]);
             ^
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.100.221
©2016-2025

Related questions

0 like 0 dislike
55 answers
[Exercise] Coding (C) - asked Nov 29, 2017 in Chapter 8: Arrays by semicolon (5.2k points)
ID: 34968 - Available when: 2017-11-30 18:00 - Due to: Unlimited
| 7.2k views
0 like 0 dislike
46 answers
[Exercise] Coding (C) - asked Nov 29, 2017 in Chapter 9: Functions by semicolon (5.2k points)
ID: 34912 - Available when: 2017-12-14 18:00 - Due to: Unlimited
| 5.8k views
0 like 0 dislike
31 answers
[Exercise] Coding (C) - asked Dec 28, 2017 in Chapter 8: Arrays by semicolon (5.2k points)
ID: 39985 - Available when: Unlimited - Due to: Unlimited
| 5.6k views
0 like 0 dislike
102 answers
[Exercise] Coding (C) - asked Dec 28, 2017 in Chapter 8: Arrays by semicolon (5.2k points)
ID: 39984 - Available when: Unlimited - Due to: Unlimited
| 12.4k views
12,783 questions
183,442 answers
172,219 comments
4,824 users