3 like 0 dislike
4k views

Write a program that let the user input two number and displays the result as the example below:

輸入兩個數字,做加減乘除的運算

Example input 1:

5 6

Example output 1:

5+6=11
5-6=-1
5*6=30
5/6=0.833333

Example input 2:

1.23 3.45

Example output 2:

1.23+3.45=4.68
1.23-3.45=-2.22
1.23*3.45=4.2435
1.23/3.45=0.356522

Remember: Your output maybe 100% correct, but your code matters!

[Exercise] Coding (C) - asked in Chapter 3: Formatted Input/Output by (12.1k points)
ID: 25729 - Available when: Unlimited - Due to: Unlimited

edited by | 4k views

116 Answers

0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
*** ** * ** * ** **** ** * a,b;
* ** ***** ****** * *
****** *** * * **** * ** * **** ** * * ** *
* ** ** ** ** * * ** *** ** *** * * * * * *** *** * **
* *** * ** *** *** ** ** * *** * ***** * ** * *
** **** * * * * ** **** ** ***** * * * * *
* ***** * ** ** ** ** * *** * * * **** *
* ** * * * * * *** 0;
}
answered by (-258 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include * * * **

int main()
{
* * *** ** * ***** * a,b;
* * **** ** ** * * ** c;
** * * *** * * * *** * * * * * * * *** * * * **
* *** ** ** * * * ** * *** ** ** ** ** %g\n",a,b,a+b);
**** * **** * ** * **** * **** * * * * *** **** * * *
*** * ** *** * * ** * * * **** * * **** ***
* *** * * * * **** * * ** * * %g",a,b,a/b);
* **** ******** * ***** * * 0;
}
answered by (-258 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
* * * ** **** * a,b;
** *** ** * * * ** * c;
** ** * * ** * *** ***** * ** * * ** * *** * *
*** * *** **** * *** * * * * **** ***
*** * *** ** ** **** *** **** * **** * *
****** * * * * ** * *** **** * *** *******
** **** * * * * * ** * ** * ***** * *
* * * * ** * **** 0;
}
answered by (-258 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
* * * * ** * * *

int main()

{

float a,b;

** ** * * * ** *** * *****
* * * * * * *** ***
*** * * * **** ** **** * ** * ****
* ** ***** *
* ** ** *** **** * * *


return 0;

}
answered by (-66 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
* * ** ** * *** ** ***** * a,b;
** * * *** * ** * ** ** * * *** ** * ** ** **
** * * * ** * * ****** ** * * ** * *** * *
** * * ** ** ***** * * ***** * * * **** * *
**** ** ** * * * * ***** * ***** ** * **
* ** *** ** * **** * *** ** ** * * * * * ***
** * ** ** ******* *** 0;
}
answered by (-108 points)
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include <stdlib.h>

int main()
{
**** * ** * *** * ** a,b;
** **** ********** ** * ** * ** ** * ***** * *** *
* ** **** ** * * *** * * * * *
***** * * * ** * *** ** * * * *** * * *
*** ** **** ** ** * * ** ** * * * **
****** * ** ** ** ** ** ** * * * ** ****** *
* * * ** * ** * ** * ** 0;
}
answered by (-127 points)
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 0
-----------Re-judge-----------
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
int main()

{

* * * * **** ** * * *** ** * * a,b;

** ***** *** ** **** ** * ** * %f",&a,&b);

* ***** * ** * ** ** * * **** * ***** ** * * *

** * * *** *** * * * * ** **** ** * ** * * * ****

*** * ** * ** *** * *** ****** * * **** *

* ** ** *** *** ***** * * * **** * *

**** **** * **** ** * ** 0;

}
answered by (-127 points)
0 like 0 dislike
Hidden content!
#include ** * ******

int main()

{
float a,b;

scanf("%f * *** *** *

* * * ***** * ** * ***** * **
*** * ** *** ** * ** ** * * ***
* * *** * *** **** * * *** **
* * ******* ** *** **** **

/*float c,d;
**** ** *** * **** * * *

** * * * * ** **** * *
* ** * **** ** ** *** * *
***** *** * * ** ** * *
* *** *** ** * * **** ****
*/
return 0;
}
answered by (-249 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main ()
{
** ** * * * * * a , b, c, d ;

* * * * *** * *** * * * * ** * * * * ***** *

* ** *** ** *** * *** ***** ** ** * + b);
* ******** *** * * * * ***** * * ******
** * *** ** *** ** ** * **** *** * b,a * b);
*** * * *** **** *** * ***** ** ***** ***

***** ** * * 0;







}
answered by (-167 points)
0 0
prog.c: In function 'main':
prog.c:4:20: error: unused variable 'd' [-Werror=unused-variable]
    float a , b, c, d ;
                    ^
prog.c:4:17: error: unused variable 'c' [-Werror=unused-variable]
    float a , b, c, d ;
                 ^
cc1: all warnings being treated as errors
0 0
prog.c: In function 'main':
prog.c:4:20: error: unused variable 'd' [-Werror=unused-variable]
    float a , b, c, d ;
                    ^
prog.c:4:17: error: unused variable 'c' [-Werror=unused-variable]
    float a , b, c, d ;
                 ^
cc1: all warnings being treated as errors
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main(void)
{
* ** * **** * * ** ****** a,b,c,d,e,f;
* ** ** * ** * *** *** **** * * * * *** %f",&a,&b);
* * *** **** * * * * ** *
******* ******* * *****
* ****** **** ** * ** * * *
* * * ** * *** **** *
** *** * *** * *** ** * *** ****** ** *** * **** ****
* ** * ** * ** * * * *** * * ****** * ** **
* * * *** *** * * * ****** * * * * **
** *** *** * ** * ** * *** * * *** * ** * *****
** * ** * ** ** * * * * * * * 0;
}
answered by (-323 points)
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
0 0
-----------Re-judge-----------
Case 0: Correct output
Case 1: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.69.7.193
©2016-2024

Related questions

1 like 0 dislike
0 answers
[Resource] asked Oct 14, 2017 in Chapter 3: Formatted Input/Output by thopd (12.1k points)
ID: 26948 - Available when: Unlimited - Due to: Unlimited
| 14 views
12,783 questions
183,443 answers
172,219 comments
4,824 users